• Dieses Thema hat 6 Antworten und 3 Teilnehmer, und wurde zuletzt aktualisiert vor 1 Jahr von dennis02121978. This post has been viewed 1021 times
Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
  • Autor
    Beiträge
  • #293
    dennis02121978
    Administrator

      Hier muß das das Klipper aus dem GitHub https://github.com/RF1000community/klipper
      installiert werden. Das ADS-EMU wird per I2C verbunden und hat die gleiche Funktionsweise wie das Originale ADS1100.

      Das Klipper kann auf jedes Klipper unterstütze Board installiert werden.

      Anleitung

      – sudo service klipper stop
      – cd /home/pi
      – mv klipper klipper_backup
      – git clone https://github.com/RF1000community/klipper
      – sudo service klipper start

      Bitte bei den Motoren SPI kontrollieren da hier das SPI Signal invertiert ist aber man kann es durch ein ! invertieren.

      Das Wiki zu der Community Version findet Ihr hier Klipper RFxxx Community

       

      #1125
      Uwe Schuster
      Teilnehmer

        Hallo,

        bei meiner Klipper Installation kommt immer der Fehler wie unten, wie bekomme ich den weg.

        Gruß Uwe

        OctoKlipper:
        Error:

        Option ‘pid_Kp’ in section ‘heater_bed’ must be specified

         

        RF1000 Firmware 1,45 Originalboard

         

         

         

        #1127
        Andre Jung
        Teilnehmer

          Hallo Uwe,

          hier hast du die einfache Lösung dafür:

          [heater_bed]
          control = pid
          pid_kp = 51.797
          pid_ki = 1.887
          pid_kd = 355.460

           

          Das ist der Auszug aus meinen  PID-Tuning am RF1000 wenn du noch den Fehler bekommst vom Extruder hier gleich auch was dazu

          [extruder]
          control = pid
          pid_kp = 20.006
          pid_ki = 1.282
          pid_kd = 78.025

           

          Gruß

          Andrè

          #1128
          Uwe Schuster
          Teilnehmer

            Hallo Andre,

             

            danke für deine Hilfe, der Fehler ist jetzt weg.

            Kannst du eventuell mir die komplette config zusenden, wenn es möglich ist.

            Gruß Uwe

            #1129
            dennis02121978
            Administrator

              Hallo UWE,

              welches Board hast du eingebaut? Man kann nicht einfach die Config an jedem Board einsetzten.

              Dennis

              #1130
              Uwe Schuster
              Teilnehmer

                Hallo Dennis,

                 

                Originalbord RF1000.

                #1131
                dennis02121978
                Administrator

                  Achso, da musst das Klipper etc vom RF1000 Forum nehmen. Wenn du das normale Klipper ohne das von denen nimmst verlierst du viele Sachen. Ich bin auf Umbau mit meinem EMU spezialisiert mit Klipper und Marlin auch Repetier 8bit.

                  Dennis

                   

                Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
                • Du musst angemeldet sein, um auf dieses Thema antworten zu können.